Another strange redirect issue

BrainStorm

Junior Member
Joined
Nov 3, 2009
Likes
0
#1
set sv_allowDownload "1"
set sv_wwwDownload "1"
seta sv_wwwBaseURL "http://www.someserver.com/dl/CODServer/COD15"
set sv_wwwDlDisconnected "1"

I cant hit any map file on the redirect.
Mod.pk3 is in abcd folder on redirect like this:
http://www.someserver.com/dl/CODServer/COD15/abcd/Mod.pk3

All maps are in Main directory on gameserver.
So on redirect like this:
http://www.someserver.com/dl/CODServer/COD15/main/map1.pk3
http://www.someserver.com/dl/CODServer/COD15/main/map2.pk3
...


Issue is:
When connecting to game server. Mod is downloaded no problem.

one or two maps are downloaded, then current map isn't downloaded but tried to be loaded by my COD client. Which results is a "couldn't load map map3.bps" message...

I'm puzzled. I've read alot on the redirects but cant see where things seem not to go right!

Thanks in advance for your help!
 

BrainStorm

Junior Member
Joined
Nov 3, 2009
Likes
0
#6
Tried both settings.

So today tested this:

I connect to gameserver. I have already map for current game playing.
I connect successfully. play the map, no problem.
map rotates.
I dont have the map localy. Instead of trying to download the map, the game tries to launch the map on my side, but I dont have it of course.
I then get the "could not load map ...bsp" message.
I dont have it so message is normal.
But why does it not download the map.
I need to shutdown my cod and restart. Then I connect, it downloads the current map only, then I can play.
Only on next map that I dont have localy that the issue arises.

Thanks alot!
 
Top Bottom